What’s Vulnerable › Vulnerabilities
CVE-2023-1655: Heap-based Buffer Overflow in gpac/gpac
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-03-27 · updated 2026-06-17
- Weakness: CWE-122
Description
Heap-based Buffer Overflow in GitHub repository gpac/gpac prior to 2.4.0.
Affected products
- GPAC: before 2.4.0 — fixed in 2.4.0
How to fix
Upgrade to a fixed version: GPAC 2.4.0. Check the vendor advisory for mitigations.
References
- https://github.com/gpac/gpac/commit/e7f96c2d3774e4ea25f952bcdf55af1dd6e919f4
- https://huntr.dev/bounties/05f1d1de-bbfd-43fe-bdf9-7f73419ce7c9
- https://github.com/gpac/gpac/commit/e7f96c2d3774e4ea25f952bcdf55af1dd6e919f4
- https://huntr.dev/bounties/05f1d1de-bbfd-43fe-bdf9-7f73419ce7c9
Get alerted when CVE-2023-1655 or the next vulnerability affects your stack