What’s Vulnerable › Vulnerabilities

CVE-2023-1663: Authenticated Resources Accessible via Forced Browsing

Description

Coverity versions prior to 2023.3.2 are vulnerable to forced browsing, which exposes authenticated resources to unauthorized actors. The root cause of this vulnerability is an insecurely configured servlet mapping for the underlying Apache Tomcat server. As a result, the downloads directory and its contents are accessible. 5.9 (CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L/E:P/RL:O/RC:C)

Affected products

How to fix

Upgrade to a fixed version: Synopsys Coverity 2023.3.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-1663 or the next vulnerability affects your stack