What’s Vulnerable › Vulnerabilities
CVE-2023-1670
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-30 · updated 2026-06-17
- Weakness: CWE-416
Description
A flaw use after free in the Linux kernel Xircom 16-bit PCMCIA (PC-card) Ethernet driver was found.A local user could use this flaw to crash the system or potentially escalate their privileges on the system.
Affected products
- Linux kernel: from 2.6.18 before 4.14.312; from 4.15 before 4.19.280; from 4.20 before 5.4.240; from 5.5 before 5.10.177; from 5.11 before 5.15.105; from 5.16 before 6.1.22 — fixed in 4.14.312, 4.19.280, 5.10.177, 5.15.105, 5.4.240, 6.1.22
How to fix
Upgrade to a fixed version: Linux kernel 4.14.312, 4.19.280, 5.10.177, 5.15.105. Check the vendor advisory for mitigations.
References
- https://lists.debian.org/debian-lts-announce/2023/05/msg00005.html
- https://lists.debian.org/debian-lts-announce/2023/05/msg00006.html
- https://lore.kernel.org/all/20230316161526.1568982-1-zyytlz.wz%40163.com/
- https://security.netapp.com/advisory/ntap-20230526-0010/
- https://lists.debian.org/debian-lts-announce/2023/05/msg00005.html
- https://lists.debian.org/debian-lts-announce/2023/05/msg00006.html
- https://lore.kernel.org/all/20230316161526.1568982-1-zyytlz.wz%40163.com/
- https://security.netapp.com/advisory/ntap-20230526-0010/
Get alerted when CVE-2023-1670 or the next vulnerability affects your stack