What’s Vulnerable › Vulnerabilities
CVE-2023-1778: Default Credential Vulnerability in GajShield Data Security Firewall
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-04-27 · updated 2026-06-17
- Weakness: CWE-287
Description
This vulnerability exists in GajShield Data Security Firewall firmware versions prior to v4.28 (except v4.21) due to insecure default credentials which allows remote attacker to login as superuser by using default username/password via web-based management interface and/or exposed SSH port thereby enabling remote attackers to execute arbitrary commands with administrative/superuser privileges on the targeted systems. The vulnerability has been addressed by forcing the user to change their default password to a new non-default password.
Affected products
- GajShield Data Security Firewall: before 4.21; from 4.22 before 4.28 — fixed in 4.21, 4.28
How to fix
Upgrade to a fixed version: GajShield Data Security Firewall 4.21, 4.28. Check the vendor advisory for mitigations.
References
- https://www.cert-in.org.in/s2cMainServlet?pageid=PUBVLNOTES01&VLCODE=CIVN-2023-0119
- https://www.cert-in.org.in/s2cMainServlet?pageid=PUBVLNOTES01&VLCODE=CIVN-2023-0119
Get alerted when CVE-2023-1778 or the next vulnerability affects your stack