What’s Vulnerable › Vulnerabilities
CVE-2023-1787
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-04-05 · updated 2026-06-17
- Weakness: CWE-400
Description
An issue has been discovered in GitLab affecting all versions starting from 15.9 before 15.9.4, all versions starting from 15.10 before 15.10.1. A search timeout could be triggered if a specific HTML payload was used in the issue description.
Affected products
- GitLab: from 15.9.0 before 15.9.4; 15.10.0 — fixed in 15.9.4
How to fix
Upgrade to a fixed version: GitLab 15.9.4. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/cves/-/blob/master/2023/CVE-2023-1787.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/394817
- https://gitlab.com/gitlab-org/cves/-/blob/master/2023/CVE-2023-1787.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/394817
Get alerted when CVE-2023-1787 or the next vulnerability affects your stack