What’s Vulnerable › Vulnerabilities
CVE-2023-1788: Insufficient Session Expiration in firefly-iii/firefly-iii
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-04-05 · updated 2026-06-17
- Weakness: CWE-613
Description
Insufficient Session Expiration in GitHub repository firefly-iii/firefly-iii prior to 6.
Affected products
- firefly-iii/firefly-iii: before 6.0.0; 6.0.0-alpha1, 6.0.0-alpha2, 6.0.0-beta1, 6.0.0-beta2 — fixed in 6.0.0
How to fix
Upgrade to a fixed version: firefly-iii/firefly-iii 6.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/firefly-iii/firefly-iii/commit/68f398f97cbe1870fc098d8460bf903b9c3fab30
- https://huntr.dev/bounties/79323c9e-e0e5-48ef-bd19-d0b09587ccb2
- https://github.com/firefly-iii/firefly-iii/commit/68f398f97cbe1870fc098d8460bf903b9c3fab30
- https://huntr.dev/bounties/79323c9e-e0e5-48ef-bd19-d0b09587ccb2
Get alerted when CVE-2023-1788 or the next vulnerability affects your stack