What’s Vulnerable › Vulnerabilities
CVE-2023-1832: Improper authorization check in the server component
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-10-04 · updated 2026-06-17
- Weakness: CWE-284
Description
An improper access control flaw was found in Candlepin. An attacker can create data scoped under another customer/tenant, which can result in loss of confidentiality and availability for the affected customer/tenant.
Affected products
- candlepin: before 4.3.7-3 — fixed in 4.3.7-3
- Red Hat Satellite 6: 6.0
How to fix
Upgrade to a fixed version: candlepin 4.3.7-3. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/security/cve/CVE-2023-1832
- https://bugzilla.redhat.com/show_bug.cgi?id=2184364
- https://access.redhat.com/security/cve/CVE-2023-1832
- https://bugzilla.redhat.com/show_bug.cgi?id=2184364
Get alerted when CVE-2023-1832 or the next vulnerability affects your stack