What’s Vulnerable › Vulnerabilities
CVE-2023-1838
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-04-05 · updated 2026-10-08
- Weakness: CWE-416
Description
A use-after-free flaw was found in vhost_net_set_backend in drivers/vhost/net.c in virtio network subcomponent in the Linux kernel due to a double fget. This flaw could allow a local attacker to crash the system, and could even lead to a kernel information leak problem.
Affected products
- Linux kernel: from 4.13 before 4.14.317; from 4.15 before 4.19.245; from 4.20 before 5.4.196; from 5.5 before 5.10.118; from 5.11 before 5.15.42; from 5.16 before 5.17.10 — fixed in 4.14.317, 4.19.245, 5.10.118, 5.15.42, 5.17.10, 5.4.196
- NetApp H300S: all versions
- NetApp H410C: all versions
- NetApp H410S: all versions
- NetApp H500S: all versions
- NetApp H700S: all versions
How to fix
Upgrade to a fixed version: Linux kernel 4.14.317, 4.19.245, 5.10.118, 5.15.42. Check the vendor advisory for mitigations.
References
- https://lore.kernel.org/netdev/20220516084213.26854-1-jasowang%40redhat.com/T/
- https://security.netapp.com/advisory/ntap-20230517-0003/
- https://lore.kernel.org/netdev/20220516084213.26854-1-jasowang%40redhat.com/T/
- https://security.netapp.com/advisory/ntap-20230517-0003/
Get alerted when CVE-2023-1838 or the next vulnerability affects your stack