What’s Vulnerable › Vulnerabilities
CVE-2023-1839: Product Addons & Fields for WooCommerce < 32.0.6 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-05-15 · updated 2026-06-17
Description
The Product Addons & Fields for WooCommerce WordPress plugin before 32.0.6 does not sanitize and escape some of its setting fields, which could allow high-privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example, in multisite setup).
Affected products
- themeisle PPOM – Product Addons & Custom Fields for WooCommerce: before 32.0.6 — fixed in 32.0.6
How to fix
Upgrade to a fixed version: themeisle PPOM – Product Addons & Custom Fields for WooCommerce 32.0.6. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/fddc5a1c-f267-4ef4-8acf-731dbecac450
- https://wpscan.com/vulnerability/fddc5a1c-f267-4ef4-8acf-731dbecac450
Get alerted when CVE-2023-1839 or the next vulnerability affects your stack