What’s Vulnerable › Vulnerabilities
CVE-2023-1841: Honeywell MPA2 Web Application XSS vulnerability
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-29 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Honeywell MPA2 Access Panel (Web server modules) allows XSS Using Invalid Characters.This issue affects MPA2 Access Panel all version prior to R1.00.08.05. Honeywell released firmware update package MPA2 firmware R1.00.08.05 which addresses this vulnerability. This version and all later versions correct the reported vulnerability.
Affected products
- Honeywell MPA2 Access Panel: before R1.00.08.05 — fixed in R1.00.08.05
How to fix
Upgrade to a fixed version: Honeywell MPA2 Access Panel R1.00.08.05. Check the vendor advisory for mitigations.
References
- https://buildings.honeywell.com/us/en/brands/our-brands/security/support-and-resources/product-resources/eol-and-security-notices
- https://https://www.honeywell.com/us/en/product-security
- https://buildings.honeywell.com/us/en/brands/our-brands/security/support-and-resources/product-resources/eol-and-security-notices
- https://https://www.honeywell.com/us/en/product-security
Get alerted when CVE-2023-1841 or the next vulnerability affects your stack