What’s Vulnerable › Vulnerabilities
CVE-2023-1892: Cross-site Scripting (XSS) - Reflected in sidekiq/sidekiq
- Severity: critical (CVSS 9.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-04-21 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Reflected in GitHub repository sidekiq/sidekiq prior to 7.0.8.
Affected products
- sidekiq/sidekiq: from 7.0.4 before 7.0.8 — fixed in 7.0.8
How to fix
Upgrade to a fixed version: sidekiq/sidekiq 7.0.8. Check the vendor advisory for mitigations.
References
- https://github.com/sidekiq/sidekiq/commit/458fdf74176a9881478c48dc5cf0269107b22214
- https://huntr.dev/bounties/e35e5653-c429-4fb8-94a3-cbc123ae4777
- https://github.com/sidekiq/sidekiq/commit/458fdf74176a9881478c48dc5cf0269107b22214
- https://huntr.dev/bounties/e35e5653-c429-4fb8-94a3-cbc123ae4777
Get alerted when CVE-2023-1892 or the next vulnerability affects your stack