What’s Vulnerable › Vulnerabilities
CVE-2023-1904
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-12-14 · updated 2026-06-17
- Weakness: CWE-532
Description
In affected versions of Octopus Server it is possible for the OpenID client secret to be logged in clear text during the configuration of Octopus Server.
Affected products
- Octopus Deploy Octopus Server: from 2022.1.2121 before 2023.1.11942; from 2023.2.2028 before 2023.2.13151; from 2023.3.317 before 2023.3.5049 — fixed in 2023.1.11942, 2023.2.13151, 2023.3.5049
How to fix
Upgrade to a fixed version: Octopus Deploy Octopus Server 2023.1.11942, 2023.2.13151, 2023.3.5049. Check the vendor advisory for mitigations.
References
- https://advisories.octopus.com/post/2023/sa2023-12/
- https://advisories.octopus.com/post/2023/sa2023-12/
Get alerted when CVE-2023-1904 or the next vulnerability affects your stack