What’s Vulnerable › Vulnerabilities
CVE-2023-1905: WP Popups < 2.1.5.1 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-05-08 · updated 2026-06-17
Description
The WP Popups WordPress plugin before 2.1.5.1 does not properly escape the href attribute of its spu-facebook-page shortcode before outputting it back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks. This is due to an insufficient fix of CVE-2023-24003
Affected products
- WP Popups: before 2.1.5.1 — fixed in 2.1.5.1
How to fix
Upgrade to a fixed version: WP Popups 2.1.5.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/b6ac3e15-6f39-4514-a50d-cca7b9457736
- https://wpscan.com/vulnerability/b6ac3e15-6f39-4514-a50d-cca7b9457736
Get alerted when CVE-2023-1905 or the next vulnerability affects your stack