What’s Vulnerable › Vulnerabilities
CVE-2023-1906
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-04-12 · updated 2026-06-17
- Weakness: CWE-122
Description
A heap-based buffer overflow issue was discovered in ImageMagick's ImportMultiSpectralQuantum() function in MagickCore/quantum-import.c. An attacker could pass specially crafted file to convert, triggering an out-of-bounds read error, allowing an application to crash, resulting in a denial of service.
Affected products
- Fedoraproject Extra Packages For Enterprise Linux: 8.0
- Fedoraproject Fedora: 37
- ImageMagick: before 6.9.12-84; 7.1.1-4 — fixed in 6.9.12-84
How to fix
Upgrade to a fixed version: ImageMagick 6.9.12-84. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/security/cve/CVE-2023-1906
- https://bugzilla.redhat.com/show_bug.cgi?id=2185714
- https://github.com/ImageMagick/ImageMagick/commit/d7a8bdd7bb33cf8e58bc01b4a4f2ea5466f8c6b3
- https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-35q2-86c7-9247
- https://github.com/ImageMagick/ImageMagick6/commit/e30c693b37c3b41723f1469d1226a2c814ca443d
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/6655G3GPS42WQM32DJHUCZALI2URQSCO/
- https://access.redhat.com/security/cve/CVE-2023-1906
- https://bugzilla.redhat.com/show_bug.cgi?id=2185714
- https://github.com/ImageMagick/ImageMagick/commit/d7a8bdd7bb33cf8e58bc01b4a4f2ea5466f8c6b3
- https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-35q2-86c7-9247
- https://github.com/ImageMagick/ImageMagick6/commit/e30c693b37c3b41723f1469d1226a2c814ca443d
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/6655G3GPS42WQM32DJHUCZALI2URQSCO/
Get alerted when CVE-2023-1906 or the next vulnerability affects your stack