What’s Vulnerable › Vulnerabilities
CVE-2023-1911: Blocksy Companion < 1.8.82 - Subscriber+ Draft Post Access
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-05-02 · updated 2026-06-17
- Weakness: CWE-639
Description
The Blocksy Companion WordPress plugin before 1.8.82 does not ensure that posts to be accessed via a shortcode are already public and can be viewed, allowing any authenticated users, such as subscriber to access draft posts for example
Affected products
- creativethemeshq Blocksy Companion: before 1.8.82 — fixed in 1.8.82
How to fix
Upgrade to a fixed version: creativethemeshq Blocksy Companion 1.8.82. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/e7c52af0-b210-4e7d-a5e0-ee0645ddc08c
- https://wpscan.com/vulnerability/e7c52af0-b210-4e7d-a5e0-ee0645ddc08c
Get alerted when CVE-2023-1911 or the next vulnerability affects your stack