What’s Vulnerable › Vulnerabilities
CVE-2023-1979: Auth bypass in Web Stories for WordPress plugin
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-05-08 · updated 2026-06-17
- Weakness: CWE-863
Description
The Web Stories for WordPress plugin supports the WordPress built-in functionality of protecting content with a password. The content is then only accessible to website visitors after entering the password. In WordPress, users with the "Author" role can create stories, but don't have the ability to edit password protected stories. The vulnerability allowed users with said role to bypass this permission check when trying to duplicate the protected story in the plugin's own dashboard, giving them access to the seemingly protected content. We recommend upgrading to version 1.32 or beyond commit ad49781c2a35c5c92ef704d4b621ab4e5cb77d68 https://github.com/GoogleForCreators/web-stories-wp/commit/ad49781c2a35c5c92ef704d4b621ab4e5cb77d68
Affected products
- google Web Stories: before 1.32.0 — fixed in 1.32.0
How to fix
Upgrade to a fixed version: google Web Stories 1.32.0. Check the vendor advisory for mitigations.
References
- https://github.com/GoogleForCreators/web-stories-wp/commit/ad49781c2a35c5c92ef704d4b621ab4e5cb77d68
- https://github.com/GoogleForCreators/web-stories-wp/releases/tag/v1.32.0
- https://github.com/GoogleForCreators/web-stories-wp/commit/ad49781c2a35c5c92ef704d4b621ab4e5cb77d68
- https://github.com/GoogleForCreators/web-stories-wp/releases/tag/v1.32.0
Get alerted when CVE-2023-1979 or the next vulnerability affects your stack