What’s Vulnerable › Vulnerabilities
CVE-2023-20009
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-01 · updated 2026-06-17
- Weakness: CWE-20
Description
A vulnerability in the Web UI and administrative CLI of the Cisco Secure Email Gateway (ESA) and Cisco Secure Email and Web Manager (SMA) could allow an authenticated remote attacker and or authenticated local attacker to escalate their privilege level and gain root access. The attacker has to have a valid user credential with at least a [[privilege of operator - validate actual name]]. The vulnerability is due to the processing of a specially crafted SNMP configuration file. An attacker could exploit this vulnerability by authenticating to the targeted device and uploading a specially crafted SNMP configuration file that when uploaded could allow for the execution of commands as root. An exploit could allow the attacker to gain root access on the device.
Affected products
- Cisco Email Security Appliance (ESA): before 12.5.3-041; from 13.0.0 before 13.0.5-007; from 13.5.0 before 13.5.4-038; from 14.0.0 before 14.2.1-020; from 14.3.0 before 14.3.0-032 — fixed in 12.5.3-041, 13.0.5-007, 13.5.4-038, 14.2.1-020, 14.3.0-032
- Cisco Secure Email And Web Manager: before 12.8.1-021; from 13.8.0 before 13.8.1-108; from 14.0.0 before 14.2.0-224; from 14.3.0 before 14.3.0-120 — fixed in 12.8.1-021, 13.8.1-108, 14.2.0-224, 14.3.0-120
How to fix
Upgrade to a fixed version: Cisco Email Security Appliance (ESA) 12.5.3-041, 13.0.5-007, 13.5.4-038, 14.2.1-020; Cisco Secure Email And Web Manager 12.8.1-021, 13.8.1-108, 14.2.0-224, 14.3.0-120. Check the vendor advisory for mitigations.
References
- https://sec.cloudapps.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-esa-sma-privesc-9DVkFpJ8
- https://sec.cloudapps.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-esa-sma-privesc-9DVkFpJ8
Get alerted when CVE-2023-20009 or the next vulnerability affects your stack