What’s Vulnerable › Vulnerabilities
CVE-2023-20011: Cisco Application Policy Infrastructure Controller and Cisco Cloud Network Controller Cross-Site Request Forgery Vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-23 · updated 2026-06-17
- Weakness: CWE-352
Description
A vulnerability in the web-based management interface of Cisco Application Policy Infrastructure Controller (APIC) and Cisco Cloud Network Controller, formerly Cisco Cloud APIC, could allow an unauthenticated, remote attacker to conduct a cross-site request forgery (CSRF) attack on an affected system. This vulnerability is due to insufficient CSRF protections for the web-based management interface on an affected system. An attacker could exploit this vulnerability by persuading a user of the interface to click a malicious link. A successful exploit could allow the attacker to perform arbitrary actions with the privilege level of the affected user. If the affected user has administrative privileges, these actions could include modifying the system configuration and creating new privileged accounts.
Affected products
- Cisco Application Policy Infrastructure Controller (APIC): from 4.2\(6\) before 5.2\(7g\); from 6.0 before 6.0\(2h\) — fixed in 5.2\(7g\), 6.0\(2h\)
- Cisco Cloud Network Controller: from 4.2\(6\) before 25.0\(5\) — fixed in 25.0\(5\)
How to fix
Upgrade to a fixed version: Cisco Application Policy Infrastructure Controller (APIC) 5.2\(7g\), 6.0\(2h\); Cisco Cloud Network Controller 25.0\(5\). Check the vendor advisory for mitigations.
References
- https://sec.cloudapps.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-capic-csrfv-DMx6KSwV
- https://sec.cloudapps.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-capic-csrfv-DMx6KSwV
Get alerted when CVE-2023-20011 or the next vulnerability affects your stack