What’s Vulnerable › Vulnerabilities
CVE-2023-20012: Cisco Nexus 9300-FX3 Series Fabric Extender for UCS Fabric Interconnects Authentication Bypass Vulnerability
- Severity: medium (CVSS 4.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-23 · updated 2026-06-17
- Weakness: CWE-287
Description
A vulnerability in the CLI console login authentication of Cisco Nexus 9300-FX3 Series Fabric Extender (FEX) when used in UCS Fabric Interconnect deployments could allow an unauthenticated attacker with physical access to bypass authentication. This vulnerability is due to the improper implementation of the password validation function. An attacker could exploit this vulnerability by logging in to the console port on an affected device. A successful exploit could allow the attacker to bypass authentication and execute a limited set of commands local to the FEX, which could cause a device reboot and denial of service (DoS) condition.
Affected products
- Cisco Nexus 93180Yc-Fx3 Firmware: all versions
- Cisco Nexus 93180Yc-Fx3S Firmware: all versions
- Cisco Ucs 64108 Firmware: all versions
- Cisco Ucs 6454 Firmware: all versions
- Cisco Ucs 6536 Firmware: all versions
- Cisco Ucs Central Software: from 4.2 before 4.2\(2d\) — fixed in 4.2\(2d\)
How to fix
Upgrade to a fixed version: Cisco Ucs Central Software 4.2\(2d\). Check the vendor advisory for mitigations.
References
- https://sec.cloudapps.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-elyfex-dos-gfvcByx
- https://sec.cloudapps.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-elyfex-dos-gfvcByx
Get alerted when CVE-2023-20012 or the next vulnerability affects your stack