What’s Vulnerable › Vulnerabilities
CVE-2023-20015: Cisco Firepower 4100 Series, Firepower 9300 Security Appliances, and UCS Fabric Interconnects Command Injection Vulnerability
- Severity: medium (CVSS 6.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-23 · updated 2026-06-17
- Weakness: CWE-78
Description
A vulnerability in the CLI of Cisco Firepower 4100 Series, Cisco Firepower 9300 Security Appliances, and Cisco UCS 6200, 6300, 6400, and 6500 Series Fabric Interconnects could allow an authenticated, local attacker to inject unauthorized commands. This vulnerability is due to insufficient input validation of commands supplied by the user. An attacker could exploit this vulnerability by authenticating to a device and submitting crafted input to the affected command. A successful exploit could allow the attacker to execute unauthorized commands within the CLI. An attacker with Administrator privileges could also execute arbitrary commands on the underlying operating system of Cisco UCS 6400 and 6500 Series Fabric Interconnects with root-level privileges.
Affected products
- Cisco Firepower Extensible Operating System (FXOS): all versions
- Cisco Ucs 6200 Firmware: all versions
- Cisco Ucs 6248Up Firmware: all versions
- Cisco Ucs 6296Up Firmware: all versions
- Cisco Ucs 6300 Firmware: all versions
- Cisco Ucs 6324 Firmware: all versions
- Cisco Ucs 6332-16Up Firmware: all versions
- Cisco Ucs 6332 Firmware: all versions
- Cisco Ucs 64108 Firmware: all versions
- Cisco Ucs 6454 Firmware: all versions
- Cisco Ucs 6536 Firmware: all versions
- Cisco Ucs Central Software: from 4.0 before 4.0\(4o\); from 4.1 before 4.1\(3k\); from 4.2 before 4.2\(2d\) — fixed in 4.0\(4o\), 4.1\(3k\), 4.2\(2d\)
How to fix
Upgrade to a fixed version: Cisco Ucs Central Software 4.0\(4o\), 4.1\(3k\), 4.2\(2d\). Check the vendor advisory for mitigations.
References
- https://sec.cloudapps.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-nxfp-cmdinj-XXBZjtR
- https://sec.cloudapps.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-nxfp-cmdinj-XXBZjtR
Get alerted when CVE-2023-20015 or the next vulnerability affects your stack