What’s Vulnerable › Vulnerabilities
CVE-2023-20040
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-20 · updated 2026-06-17
- Weakness: CWE-23
Description
A vulnerability in the NETCONF service of Cisco Network Services Orchestrator (NSO) could allow an authenticated, remote attacker to cause a denial of service (DoS) on an affected system that is running as the root user. To exploit this vulnerability, the attacker must be a member of the admin group. This vulnerability exists because user-supplied input is not properly validated when NETCONF is used to upload packages to an affected device. An attacker could exploit this vulnerability by uploading a specially crafted package file. A successful exploit could allow the attacker to write crafted files to arbitrary locations on the filesystem or delete arbitrary files from the filesystem of an affected device, resulting in a DoS condition. Note: By default, during install, Cisco NSO will be set up to run as the root user unless the --run-as-user option is used.
Affected products
- Cisco Network Services Orchestrator: from 3.3 before 5.4.7; from 5.5 before 5.5.6; from 5.6 before 5.6.7; from 5.7 before 5.7.4; 5.8 — fixed in 5.4.7, 5.5.6, 5.6.7, 5.7.4
How to fix
Upgrade to a fixed version: Cisco Network Services Orchestrator 5.4.7, 5.5.6, 5.6.7, 5.7.4. Check the vendor advisory for mitigations.
References
- https://sec.cloudapps.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-nso-path-trvsl-zjBeMkZg
- https://sec.cloudapps.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-nso-path-trvsl-zjBeMkZg
Get alerted when CVE-2023-20040 or the next vulnerability affects your stack