What’s Vulnerable › Vulnerabilities
CVE-2023-20050: Cisco NX-OS Software CLI Command Injection Vulnerability
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-23 · updated 2026-06-17
- Weakness: CWE-78
Description
A vulnerability in the CLI of Cisco NX-OS Software could allow an authenticated, local attacker to execute arbitrary commands on the underlying operating system of an affected device. This vulnerability is due to insufficient validation of arguments that are passed to specific CLI commands. An attacker could exploit this vulnerability by including crafted input as the argument of an affected command. A successful exploit could allow the attacker to execute arbitrary commands on the underlying operating system with the privileges of the currently logged-in user.
Affected products
- Cisco NX-OS: before 8.2\(9\); before 9.3\(10\); before 10.2\(4\) — fixed in 10.2\(4\), 8.2\(9\), 9.3\(10\)
How to fix
Upgrade to a fixed version: Cisco NX-OS 10.2\(4\), 8.2\(9\), 9.3\(10\). Check the vendor advisory for mitigations.
References
- https://sec.cloudapps.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-nxos-cli-cmdinject-euQVK9u
- https://sec.cloudapps.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-nxos-cli-cmdinject-euQVK9u
Get alerted when CVE-2023-20050 or the next vulnerability affects your stack