What’s Vulnerable › Vulnerabilities
CVE-2023-20056: Cisco Access Point Software Denial of Service Vulnerability
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-23 · updated 2026-06-17
- Weakness: CWE-78
Description
A vulnerability in the management CLI of Cisco access point (AP) software could allow an authenticated, local attacker to cause a denial of service (DoS) condition on an affected device. This vulnerability is due to insufficient input validation of commands supplied by the user. An attacker could exploit this vulnerability by authenticating to a device and submitting crafted input to the affected command. A successful exploit could allow the attacker to cause an affected device to reload spontaneously, resulting in a DoS condition.
Affected products
- Cisco Mobility Express 1800 Access Point Series: before 17.9.0.135 — fixed in 17.9.0.135
- Cisco IOS XE: before 16.12.8; from 17.1 before 17.3.6; from 17.4 before 17.6.5; from 17.7 before 17.9.2 — fixed in 16.12.8, 17.3.6, 17.6.5, 17.9.2
- Cisco Wireless LAN Controller (WLC): before 8.10.183.0 — fixed in 8.10.183.0
How to fix
Upgrade to a fixed version: Cisco Mobility Express 1800 Access Point Series 17.9.0.135; Cisco IOS XE 16.12.8, 17.3.6, 17.6.5, 17.9.2; Cisco Wireless LAN Controller (WLC) 8.10.183.0. Check the vendor advisory for mitigations.
References
- https://sec.cloudapps.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-ap-cli-dos-tc2EKEpu
- https://sec.cloudapps.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-ap-cli-dos-tc2EKEpu
Get alerted when CVE-2023-20056 or the next vulnerability affects your stack