What’s Vulnerable › Vulnerabilities
CVE-2023-20058
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-20 · updated 2026-06-17
- Weakness: CWE-79
Description
A vulnerability in the web-based management interface of Cisco Unified Intelligence Center could allow an unauthenticated, remote attacker to conduct a reflected cross-site scripting (XSS) attack against a user of the interface. This vulnerability exists because the web-based management interface does not properly validate user-supplied input. An attacker could exploit this vulnerability by persuading a user of the interface to click a crafted link. A successful exploit could allow the attacker to execute arbitrary script code in the context of the affected interface or access sensitive browser-based information.
Affected products
- Cisco Packaged Contact Center Enterprise: from 9.0\(1\) before 12.5\(1\)_su2_es05; from 12.5\(1\)_su2 before 12.5\(1\)_su2_es05 — fixed in 12.5\(1\)_su2_es05
- Cisco Unified Contact Center Enterprise: before 12.5\(1\)_es02; from 12.5\(2\) before 12.6\(1\)_es06; from 12.6\(1\) before 12.6\(1\)_es06 — fixed in 12.5\(1\)_es02, 12.6\(1\)_es06
- Cisco Unified Contact Center Express: before 12.5\(1\)_su2_es05; from 12.5\(1\)_su2 before 12.5\(1\)_su2_es05 — fixed in 12.5\(1\)_su2_es05
- Cisco Unified Intelligence Center: before 12.5\(1\)_es02; from 12.6\(1\) before 12.6\(1\)_es06; from 12.6\(1\)_es2 before 12.6\(1\)_es06 — fixed in 12.5\(1\)_es02, 12.6\(1\)_es06
How to fix
Upgrade to a fixed version: Cisco Packaged Contact Center Enterprise 12.5\(1\)_su2_es05; Cisco Unified Contact Center Enterprise 12.5\(1\)_es02, 12.6\(1\)_es06; Cisco Unified Contact Center Express 12.5\(1\)_su2_es05; Cisco Unified Intelligence Center 12.5\(1\)_es02, 12.6\(1\)_es06. Check the vendor advisory for mitigations.
References
- https://sec.cloudapps.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-cuis-xss-Omm8jyBX
- https://sec.cloudapps.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-cuis-xss-Omm8jyBX
Get alerted when CVE-2023-20058 or the next vulnerability affects your stack