What’s Vulnerable › Vulnerabilities
CVE-2023-20068: Cisco Prime Infrastructure Reflected Cross-Site Scripting Vulnerability
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-04-05 · updated 2026-06-17
- Weakness: CWE-79
Description
A vulnerability in the web-based management interface of Cisco Prime Infrastructure Software could allow an unauthenticated, remote attacker to conduct a reflected cross-site scripting (XSS) attack against a user of the interface on an affected device. This vulnerability is due to insufficient validation of user-supplied input. An attacker could exploit this vulnerability by persuading a user of the web-based management interface on an affected device to click a crafted link. A successful exploit could allow the attacker to execute arbitrary script code in the context of the affected interface or to access sensitive, browser-based information.
Affected products
- Cisco Prime Infrastructure: before 3.10.3 — fixed in 3.10.3
How to fix
Upgrade to a fixed version: Cisco Prime Infrastructure 3.10.3. Check the vendor advisory for mitigations.
References
- https://sec.cloudapps.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-cisco-pi-xss-PU6dnfD9
- https://sec.cloudapps.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-cisco-pi-xss-PU6dnfD9
Get alerted when CVE-2023-20068 or the next vulnerability affects your stack