What’s Vulnerable › Vulnerabilities
CVE-2023-20075
- Severity: medium (CVSS 6.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-01 · updated 2026-06-17
- Weakness: CWE-77
Description
Vulnerability in the CLI of Cisco Secure Email Gateway could allow an authenticated, remote attacker to execute arbitrary commands. These vulnerability is due to improper input validation in the CLI. An attacker could exploit this vulnerability by injecting operating system commands into a legitimate command. A successful exploit could allow the attacker to escape the restricted command prompt and execute arbitrary commands on the underlying operating system. To successfully exploit this vulnerability, an attacker would need valid Administrator credentials.
Affected products
- Cisco Email Security Appliance (ESA): from 12.5.0 before 12.5.3-041; from 13.0.0 before 13.0.5-007; from 13.5.0 before 13.5.4-038; from 14.0.0 before 14.2.1-020; from 14.3.0 before 14.3.0-032 — fixed in 12.5.3-041, 13.0.5-007, 13.5.4-038, 14.2.1-020, 14.3.0-032
How to fix
Upgrade to a fixed version: Cisco Email Security Appliance (ESA) 12.5.3-041, 13.0.5-007, 13.5.4-038, 14.2.1-020. Check the vendor advisory for mitigations.
References
- https://sec.cloudapps.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-esa-sma-privesc-9DVkFpJ8
- https://sec.cloudapps.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-esa-sma-privesc-9DVkFpJ8
Get alerted when CVE-2023-20075 or the next vulnerability affects your stack