What’s Vulnerable › Vulnerabilities
CVE-2023-2008: Kernel: udmabuf: improper validation of array index leading to local privilege escalation
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-04-14 · updated 2026-08-10
- Weakness: CWE-129
Description
A flaw was found in the Linux kernel's udmabuf device driver, within a fault handler. This issue occurs due to the lack of proper validation of user-supplied data, which can result in memory access past the end of an array. This may allow an attacker to escalate privileges and execute arbitrary code in the context of the kernel.
Affected products
- Linux kernel: before 5.19; from 4.20 before 5.4.202; from 5.5 before 5.10.127; from 5.11 before 5.15.51; from 5.16 before 5.18.8; 5.19, 5.19-rc1, 5.19-rc2, 5.19-rc3 — fixed in 5.10.127, 5.15.51, 5.18.8, 5.19, 5.4.202
How to fix
Upgrade to a fixed version: Linux kernel 5.10.127, 5.15.51, 5.18.8, 5.19. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2022:7933
- https://access.redhat.com/errata/RHSA-2022:8267
- https://access.redhat.com/errata/RHSA-2023:3465
- https://access.redhat.com/errata/RHSA-2023:3470
- https://access.redhat.com/errata/RHSA-2023:3490
- https://access.redhat.com/security/cve/CVE-2023-2008
- https://bugzilla.redhat.com/show_bug.cgi?id=2186862
- https://www.zerodayinitiative.com/advisories/ZDI-23-441/
- https://bugzilla.redhat.com/show_bug.cgi?id=2186862
- https://github.com/torvalds/linux/commit/05b252cccb2e5c3f56119d25de684b4f810ba4
- https://security.netapp.com/advisory/ntap-20230517-0007/
- https://www.zerodayinitiative.com/advisories/ZDI-23-441/
Get alerted when CVE-2023-2008 or the next vulnerability affects your stack