What’s Vulnerable › Vulnerabilities
CVE-2023-20097: Cisco Access Point Software Command Injection Vulnerability
- Severity: medium (CVSS 6.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-23 · updated 2026-06-17
- Weakness: CWE-77
Description
A vulnerability in Cisco access points (AP) software could allow an authenticated, local attacker to inject arbitrary commands and execute them with root privileges. This vulnerability is due to improper input validation of commands that are issued from a wireless controller to an AP. An attacker with Administrator access to the CLI of the controller could exploit this vulnerability by issuing a command with crafted arguments. A successful exploit could allow the attacker to gain full root access on the AP.
Affected products
- Cisco Mobility Express 1800 Access Point Series: before 17.9.0.135 — fixed in 17.9.0.135
- Cisco IOS XE: before 16.12.8; from 17.1 before 17.3.6; from 17.4 before 17.6.5; from 17.7 before 17.9.2 — fixed in 16.12.8, 17.3.6, 17.6.5, 17.9.2
- Cisco Wireless LAN Controller (WLC): before 8.10.183.0 — fixed in 8.10.183.0
How to fix
Upgrade to a fixed version: Cisco Mobility Express 1800 Access Point Series 17.9.0.135; Cisco IOS XE 16.12.8, 17.3.6, 17.6.5, 17.9.2; Cisco Wireless LAN Controller (WLC) 8.10.183.0. Check the vendor advisory for mitigations.
References
- https://sec.cloudapps.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-aironetap-cmdinj-6bjT4FL8
- https://sec.cloudapps.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-aironetap-cmdinj-6bjT4FL8
Get alerted when CVE-2023-20097 or the next vulnerability affects your stack