What’s Vulnerable › Vulnerabilities
CVE-2023-2010: Forminator < 1.24.1 - Unauthenticated Race Condition on poll vote
- Severity: low (CVSS 3.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-07-04 · updated 2026-06-17
- Weakness: CWE-362
Description
The Forminator WordPress plugin before 1.24.1 does not use an atomic operation to check whether a user has already voted, and then update that information. This leads to a Race Condition that may allow a single user to vote multiple times on a poll.
Affected products
- WPMU DEV Forminator: before 1.24.1 — fixed in 1.24.1
How to fix
Upgrade to a fixed version: WPMU DEV Forminator 1.24.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/d0da4c0d-622f-4310-a867-6bfdb474073a
- https://wpscan.com/vulnerability/d0da4c0d-622f-4310-a867-6bfdb474073a
Get alerted when CVE-2023-2010 or the next vulnerability affects your stack