What’s Vulnerable › Vulnerabilities
CVE-2023-20129: Cisco Prime Infrastructure and Cisco Evolved Programmable Network Manager Vulnerabilities
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-04-05 · updated 2026-06-17
- Weakness: CWE-27
Description
Multiple vulnerabilities in the web-based management interface of Cisco Prime Infrastructure and Cisco Evolved Programmable Network Manager (EPNM) could allow a remote attacker to obtain privileged information and conduct cross-site scripting (XSS) and cross-site request forgery (CSRF) attacks. For more information about these vulnerabilities, see the Details section of this advisory.
Affected products
- Cisco Evolved Programmable Network Manager (EPNM): before 5.0.2.5; from 5.1 before 5.1.4.2; from 6.0 before 6.0.2.1; from 6.1 before 6.1.1.1 — fixed in 5.0.2.5, 5.1.4.2, 6.0.2.1, 6.1.1.1
- Cisco Prime Infrastructure: through 3.7; from 3.10 before 3.10.2; 3.8, 3.8.1, 3.9, 3.9.1 — fixed in 3.10.2
How to fix
Upgrade to a fixed version: Cisco Evolved Programmable Network Manager (EPNM) 5.0.2.5, 5.1.4.2, 6.0.2.1, 6.1.1.1; Cisco Prime Infrastructure 3.10.2. Check the vendor advisory for mitigations.
References
- https://sec.cloudapps.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-pi-epnm-eRPWAXLe
- https://sec.cloudapps.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-pi-epnm-eRPWAXLe
Get alerted when CVE-2023-20129 or the next vulnerability affects your stack