What’s Vulnerable › Vulnerabilities
CVE-2023-2017: Improper Control of Generation of Code in Twig Rendered Views in Shopware
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-04-17 · updated 2026-10-24
- Weakness: CWE-184
Description
Server-side Template Injection (SSTI) in Shopware 6 (<= v6.4.20.0, v6.5.0.0-rc1 <= v6.5.0.0-rc4), affecting both shopware/core and shopware/platform GitHub repositories, allows remote attackers with access to a Twig environment without the Sandbox extension to bypass the validation checks in `Shopware\Core\Framework\Adapter\Twig\SecurityExtension` and call any arbitrary PHP function and thus execute arbitrary code/commands via usage of fully-qualified names, supplied as array of strings, when referencing callables. Users are advised to upgrade to v6.4.20.1 to resolve this issue. This is a bypass of CVE-2023-22731.
Affected products
- shopware: from 6.1.0 through 6.4.20.0; 6.5.0.0-rc1, 6.5.0.0-rc2, 6.5.0.0-rc3
References
- https://docs.shopware.com/en/shopware-6-en/security-updates/security-update-04-2023
- https://github.com/shopware/platform/security/advisories/GHSA-7v2v-9rm4-7m8f
- https://starlabs.sg/advisories/23/23-2017/
- https://docs.shopware.com/en/shopware-6-en/security-updates/security-update-04-2023
- https://github.com/shopware/platform/security/advisories/GHSA-7v2v-9rm4-7m8f
- https://starlabs.sg/advisories/23/23-2017/
Get alerted when CVE-2023-2017 or the next vulnerability affects your stack