What’s Vulnerable › Vulnerabilities
CVE-2023-20173: Cisco Identity Services Engine XML External Entity Injection Vulnerabilities
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-05-18 · updated 2026-06-17
- Weakness: CWE-611
Description
Multiple vulnerabilities in the web-based management interface of Cisco Identity Services Engine (ISE) could allow an authenticated, remote attacker to read arbitrary files or conduct a server-side request forgery (SSRF) attack through an affected device. To exploit these vulnerabilities, an attacker must have valid Administrator credentials on the affected device. For more information about these vulnerabilities, see the Details section of this advisory.
Affected products
- Cisco Identity Services Engine: before 3.0.0; 3.0.0, 3.0.0-patch1, 3.0.0-patch2, 3.0.0-patch3, 3.0.0-patch4, 3.0.0-patch5 (+10) — fixed in 3.0.0
How to fix
Upgrade to a fixed version: Cisco Identity Services Engine 3.0.0. Check the vendor advisory for mitigations.
References
- https://sec.cloudapps.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-ise-xxe-inj-696OZTCm
- https://sec.cloudapps.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-ise-xxe-inj-696OZTCm
Get alerted when CVE-2023-20173 or the next vulnerability affects your stack