What’s Vulnerable › Vulnerabilities
CVE-2023-20205
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-16 · updated 2026-06-17
- Weakness: CWE-79
Description
Multiple vulnerabilities in the web-based management interface of Cisco Prime Infrastructure and Cisco Evolved Programmable Network Manager (EPNM) could allow an authenticated, remote attacker to conduct a stored cross-site scripting (XSS) attack against a user of the interface on an affected device. These vulnerabilities are due to insufficient validation of user-supplied input. An attacker could exploit these vulnerabilities by persuading a user of an affected interface to view a page containing malicious HTML or script content. A successful exploit could allow the attacker to execute arbitrary script code in the context of the affected interface or access sensitive, browser-based information. To exploit these vulnerabilities, the attacker must have valid credentials to access the web-based management interface of the affected device.
Affected products
- Cisco Evolved Programmable Network Manager (EPNM): before 7.1 — fixed in 7.1
- Cisco Prime Infrastructure: before 3.10.4 — fixed in 3.10.4
How to fix
Upgrade to a fixed version: Cisco Evolved Programmable Network Manager (EPNM) 7.1; Cisco Prime Infrastructure 3.10.4. Check the vendor advisory for mitigations.
References
- https://sec.cloudapps.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-pi-epnm-BFjSRJP5
- https://sec.cloudapps.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-pi-epnm-BFjSRJP5
Get alerted when CVE-2023-20205 or the next vulnerability affects your stack