What’s Vulnerable › Vulnerabilities
CVE-2023-20214
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-03 · updated 2026-06-17
- Weakness: CWE-287
Description
A vulnerability in the request authentication validation for the REST API of Cisco SD-WAN vManage software could allow an unauthenticated, remote attacker to gain read permissions or limited write permissions to the configuration of an affected Cisco SD-WAN vManage instance. This vulnerability is due to insufficient request validation when using the REST API feature. An attacker could exploit this vulnerability by sending a crafted API request to an affected vManage instance. A successful exploit could allow the attacker to retrieve information from and send information to the configuration of the affected Cisco vManage instance. This vulnerability only affects the REST API and does not affect the web-based management interface or the CLI.
Affected products
- Cisco Catalyst SD-WAN Manager: from 20.6.4 before 20.6.4.2; from 20.6.5 before 20.6.5.5; from 20.7 before 20.9.3.2; from 20.11 before 20.11.1.2; 20.6.3.3 — fixed in 20.11.1.2, 20.6.4.2, 20.6.5.5, 20.9.3.2
- Cisco Sd-Wan Vmanage: from 20.10 before 20.10.1.2 — fixed in 20.10.1.2
How to fix
Upgrade to a fixed version: Cisco Catalyst SD-WAN Manager 20.11.1.2, 20.6.4.2, 20.6.5.5, 20.9.3.2; Cisco Sd-Wan Vmanage 20.10.1.2. Check the vendor advisory for mitigations.
References
- https://sec.cloudapps.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-vmanage-unauthapi-sphCLYPA
- https://sec.cloudapps.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-vmanage-unauthapi-sphCLYPA
Get alerted when CVE-2023-20214 or the next vulnerability affects your stack