What’s Vulnerable › Vulnerabilities
CVE-2023-20217
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-16 · updated 2026-06-17
- Weakness: CWE-250
Description
A vulnerability in the CLI of Cisco ThousandEyes Enterprise Agent, Virtual Appliance installation type, could allow an authenticated, local attacker to elevate privileges on an affected device. This vulnerability is due to insufficient input validation by the operating system CLI. An attacker could exploit this vulnerability by issuing certain commands using sudo. A successful exploit could allow the attacker to view arbitrary files as root on the underlying operating system. The attacker must have valid credentials on the affected device.
Affected products
- Cisco ThousandEyes Recorder Application: before 0.230 — fixed in 0.230
- Cisco Thousandeyes Recorder: all versions
How to fix
Upgrade to a fixed version: Cisco ThousandEyes Recorder Application 0.230. Check the vendor advisory for mitigations.
References
- https://sec.cloudapps.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-te-va-priv-esc-PUdgrx8E
- https://sec.cloudapps.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-te-va-priv-esc-PUdgrx8E
Get alerted when CVE-2023-20217 or the next vulnerability affects your stack