What’s Vulnerable › Vulnerabilities
CVE-2023-20271
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-01-17 · updated 2026-06-17
- Weakness: CWE-89
Description
A vulnerability in the web-based management interface of Cisco Prime Infrastructure and Cisco Evolved Programmable Network Manager (EPNM) could allow an authenticated, remote attacker to conduct SQL injection attacks on an affected system. This vulnerability is due to improper validation of user-submitted parameters. An attacker could exploit this vulnerability by authenticating to the application and sending malicious requests to an affected system. A successful exploit could allow the attacker to obtain and modify sensitive information that is stored in the underlying database.
Affected products
- Cisco Evolved Programmable Network Manager (EPNM): before 7.1.1 — fixed in 7.1.1
- Cisco Prime Infrastructure: before 3.10.4; 3.10.4, 3.10.4-update_1 — fixed in 3.10.4
How to fix
Upgrade to a fixed version: Cisco Evolved Programmable Network Manager (EPNM) 7.1.1; Cisco Prime Infrastructure 3.10.4. Check the vendor advisory for mitigations.
References
- https://sec.cloudapps.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-pi-epnm-wkZJeyeq
- https://sec.cloudapps.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-pi-epnm-wkZJeyeq
Get alerted when CVE-2023-20271 or the next vulnerability affects your stack