What’s Vulnerable › Vulnerabilities
CVE-2023-2033: Google Chromium V8 Type Confusion Vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2023-04-17
- EPSS: 40.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-04-14 · updated 2026-06-17
- Weakness: CWE-843
Description
Type confusion in V8 in Google Chrome prior to 112.0.5615.121 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page. (Chromium security severity: High)
Affected products
- Couchbase Server: before 7.1.5; 7.2.0 — fixed in 7.1.5
- Debian Linux: 11.0
- Fedoraproject Fedora: 36, 37, 38
- Google Chrome: before 112.0.5615.121 — fixed in 112.0.5615.121
How to fix
Upgrade to a fixed version: Couchbase Server 7.1.5; Google Chrome 112.0.5615.121. Check the vendor advisory for mitigations.
References
- https://chromereleases.googleblog.com/2023/04/stable-channel-update-for-desktop_14.html
- https://crbug.com/1432210
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/4AOSGAOPXLBK4A5ZRTVZ4M6QKVLSWMWG/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/ES2CDRHR2Y4WY6DNDIAPYZFXJU3ZBFAV/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/FEJZMAUB4XP44HSHEBDWEKFGA7DUHY42/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/IHHD6KNH4WLUE6JG6HRQZWNAJMHJ32X7/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/RJQI63HWZFL6M26Q6UOHKDY6LD2PFC5Z/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/SLO7BL2MHZYPY6O3OAEAQL3SKYMGGO6M/
- https://security.gentoo.org/glsa/202309-17
- https://www.couchbase.com/alerts/
- https://www.debian.org/security/2023/dsa-5390
- https://chromereleases.googleblog.com/2023/04/stable-channel-update-for-desktop_14.html
Get alerted when CVE-2023-2033 or the next vulnerability affects your stack