What’s Vulnerable › Vulnerabilities
CVE-2023-20855
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-21 · updated 2026-06-17
- Weakness: CWE-611
Description
VMware vRealize Orchestrator contains an XML External Entity (XXE) vulnerability. A malicious actor, with non-administrative access to vRealize Orchestrator, may be able to use specially crafted input to bypass XML parsing restrictions leading to access to sensitive information or possible escalation of privileges.
Affected products
- VMware vRealize Automation: from 8.0 before 8.11.1 — fixed in 8.11.1
- VMware Vrealize Orchestrator: from 8.0 before 8.11.1 — fixed in 8.11.1
- VMware vRealize Orchestrator, VMware vRealize Automation, VMware Cloud Foundation: VMware vRealize Orchestrator 8.x
How to fix
Upgrade to a fixed version: VMware vRealize Automation 8.11.1; VMware Vrealize Orchestrator 8.11.1. Check the vendor advisory for mitigations.
References
- https://www.vmware.com/security/advisories/VMSA-2023-0005.html
- https://www.vmware.com/security/advisories/VMSA-2023-0005.html
Get alerted when CVE-2023-20855 or the next vulnerability affects your stack