What’s Vulnerable › Vulnerabilities

CVE-2023-20862

Description

In Spring Security, versions 5.7.x prior to 5.7.8, versions 5.8.x prior to 5.8.3, and versions 6.0.x prior to 6.0.3, the logout support does not properly clean the security context if using serialized versions. Additionally, it is not possible to explicitly save an empty security context to the HttpSessionSecurityContextRepository. This vulnerability can keep users authenticated even after they performed logout. Users of affected versions should apply the following mitigation. 5.7.x users should upgrade to 5.7.8. 5.8.x users should upgrade to 5.8.3. 6.0.x users should upgrade to 6.0.3.

Affected products

How to fix

Upgrade to a fixed version: Spring Security 5.7.8, 5.8.3, 6.0.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-20862 or the next vulnerability affects your stack