What’s Vulnerable › Vulnerabilities

CVE-2023-20863

Description

In spring framework versions prior to 5.2.24 release+ ,5.3.27+ and 6.0.8+ , it is possible for a user to provide a specially crafted SpEL expression that may cause a denial-of-service (DoS) condition.

Affected products

How to fix

Upgrade to a fixed version: Spring Framework 5.2.24, 5.3.27, 6.0.8. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-20863 or the next vulnerability affects your stack