What’s Vulnerable › Vulnerabilities
CVE-2023-20873
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-04-20 · updated 2026-06-17
Description
In Spring Boot versions 3.0.0 - 3.0.5, 2.7.0 - 2.7.10, and older unsupported versions, an application that is deployed to Cloud Foundry could be susceptible to a security bypass. Users of affected versions should apply the following mitigation: 3.0.x users should upgrade to 3.0.6+. 2.7.x users should upgrade to 2.7.11+. Users of older, unsupported versions should upgrade to 3.0.6+ or 2.7.11+.
Affected products
- Spring Boot: before 2.5.15; from 2.6.0 before 2.6.14; from 2.7.0 before 2.7.11; from 3.0.0 before 3.0.6 — fixed in 2.5.15, 2.6.14, 2.7.11, 3.0.6
- Spring Boot: from Spring Boot versions 3.0.0 through 3.0.5, 2.7.0 - 2.7.10, and older unsupported versions
How to fix
Upgrade to a fixed version: Spring Boot 2.5.15, 2.6.14, 2.7.11, 3.0.6. Check the vendor advisory for mitigations.
References
- https://security.netapp.com/advisory/ntap-20230601-0009/
- https://spring.io/blog/2023/05/18/spring-boot-2-5-15-and-2-6-15-available-now
- https://spring.io/security/cve-2023-20873
- https://security.netapp.com/advisory/ntap-20230601-0009/
- https://spring.io/blog/2023/05/18/spring-boot-2-5-15-and-2-6-15-available-now
- https://spring.io/security/cve-2023-20873
Get alerted when CVE-2023-20873 or the next vulnerability affects your stack