What’s Vulnerable › Vulnerabilities

CVE-2023-20882

Description

In Cloud foundry routing release versions from 0.262.0 and prior to 0.266.0,a bug in the gorouter process can lead to a denial of service of applications hosted on Cloud Foundry. Under the right circumstances, when client connections are closed prematurely, gorouter marks the currently selected backend as failed and removes it from the routing pool.

Affected products

How to fix

Upgrade to a fixed version: Cloud Foundry cf-deployment 29.0.0; Cloud Foundry Routing 0.266.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-20882 or the next vulnerability affects your stack