What’s Vulnerable › Vulnerabilities
CVE-2023-20883
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-05-26 · updated 2026-06-17
- Weakness: CWE-400
Description
In Spring Boot versions 3.0.0 - 3.0.6, 2.7.0 - 2.7.11, 2.6.0 - 2.6.14, 2.5.0 - 2.5.14 and older unsupported versions, there is potential for a denial-of-service (DoS) attack if Spring MVC is used together with a reverse proxy cache.
Affected products
- Spring Boot: before 2.5.14; from 2.6.0 through 2.6.14; from 2.7.0 through 2.7.11; from 3.0.0 through 3.0.6 — fixed in 2.5.14
- Spring Boot: from Spring Boot versions 3.0.0 through 3.0.6, 2.7.0 - 2.7.11, 2.6.0 - 2.6.14, 2.5.0 - 2.5.14 and older unsupported versions
How to fix
Upgrade to a fixed version: Spring Boot 2.5.14. Check the vendor advisory for mitigations.
References
- https://security.netapp.com/advisory/ntap-20230703-0008/
- https://spring.io/security/cve-2023-20883
- https://security.netapp.com/advisory/ntap-20230703-0008/
- https://spring.io/security/cve-2023-20883
Get alerted when CVE-2023-20883 or the next vulnerability affects your stack