What’s Vulnerable › Vulnerabilities
CVE-2023-20893
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-06-22 · updated 2026-06-17
- Weakness: CWE-416
Description
The VMware vCenter Server contains a use-after-free vulnerability in the implementation of the DCERPC protocol. A malicious actor with network access to vCenter Server may exploit this issue to execute arbitrary code on the underlying operating system that hosts vCenter Server.
Affected products
- VMware vCenter Server: before 7.0; 7.0, 7.0-a, 7.0-b, 7.0-c, 7.0-d, 7.0-update1 (+26) — fixed in 7.0
- VMware Cloud Foundation (vCenter Server): from 5.x before 7.0 U3m, 8.0 U1b; from 4.x before 7.0 U3m, 8.0 U1b — fixed in 7.0 U3m, 8.0 U1b
- VMware vCenter Server (vCenter Server): from 8.0 before 8.0 U1b; from 7.0 before 7.0 u3m — fixed in 8.0 U1b, 7.0 u3m
How to fix
Upgrade to a fixed version: VMware vCenter Server 7.0; VMware Cloud Foundation (vCenter Server) 7.0 U3m, 8.0 U1b; VMware vCenter Server (vCenter Server) 8.0 U1b, 7.0 u3m. Check the vendor advisory for mitigations.
References
- https://www.talosintelligence.com/vulnerability_reports/TALOS-2023-1799
- https://www.vmware.com/security/advisories/VMSA-2023-0014.html
- https://www.talosintelligence.com/vulnerability_reports/TALOS-2023-1799
- https://www.vmware.com/security/advisories/VMSA-2023-0014.html
Get alerted when CVE-2023-20893 or the next vulnerability affects your stack