What’s Vulnerable › Vulnerabilities
CVE-2023-20896
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-06-22 · updated 2026-06-17
- Weakness: CWE-125
Description
The VMware vCenter Server contains an out-of-bounds read vulnerability in the implementation of the DCERPC protocol. A malicious actor with network access to vCenter Server may trigger an out-of-bounds read by sending a specially crafted packet leading to denial-of-service of certain services (vmcad, vmdird, and vmafdd).
Affected products
- VMware vCenter Server: from 4.0 before 7.0; 7.0, 7.0-a, 7.0-b, 7.0-c, 7.0-d, 7.0-update1 (+26) — fixed in 7.0
- VMware Cloud Foundation (vCenter Server): from 5.x before 7.0 U3m, 8.0 U1b; from 4.x before 7.0 U3m, 8.0 U1b — fixed in 7.0 U3m, 8.0 U1b
- VMware vCenter Server (vCenter Server): from 8.0 before 8.0 U1b; from 7.0 before 7.0 u3m — fixed in 8.0 U1b, 7.0 u3m
How to fix
Upgrade to a fixed version: VMware vCenter Server 7.0; VMware Cloud Foundation (vCenter Server) 7.0 U3m, 8.0 U1b; VMware vCenter Server (vCenter Server) 8.0 U1b, 7.0 u3m. Check the vendor advisory for mitigations.
References
- https://www.talosintelligence.com/vulnerability_reports/TALOS-2023-1800
- https://www.vmware.com/security/advisories/VMSA-2023-0014.html
- https://www.talosintelligence.com/vulnerability_reports/TALOS-2023-1800
- https://www.vmware.com/security/advisories/VMSA-2023-0014.html
Get alerted when CVE-2023-20896 or the next vulnerability affects your stack