What’s Vulnerable › Vulnerabilities
CVE-2023-2091: KylinSoft youker-assistant adjust_cpufreq_scaling_governer os command injection
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-04-15 · updated 2026-06-17
- Weakness: CWE-78
Description
A vulnerability classified as critical was found in KylinSoft youker-assistant on KylinOS. Affected by this vulnerability is the function adjust_cpufreq_scaling_governer. The manipulation leads to os command injection. It is possible to launch the attack on the local host. The exploit has been disclosed to the public and may be used. Upgrading to version 3.1.4.13 is able to address this issue. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-226099.
Affected products
- Kylinos Youker-Assistant: before 3.1.4.13 — fixed in 3.1.4.13
How to fix
Upgrade to a fixed version: Kylinos Youker-Assistant 3.1.4.13. Check the vendor advisory for mitigations.
References
- https://github.com/i900008/vulndb/blob/main/youker-assistant_vuln.md
- https://kylinos.cn/support/loophole/patch/3375.html
- https://vuldb.com/?ctiid.226099
- https://vuldb.com/?id.226099
- https://github.com/i900008/vulndb/blob/main/youker-assistant_vuln.md
- https://kylinos.cn/support/loophole/patch/3375.html
- https://vuldb.com/?ctiid.226099
- https://vuldb.com/?id.226099
Get alerted when CVE-2023-2091 or the next vulnerability affects your stack