What’s Vulnerable › Vulnerabilities
CVE-2023-2106: Weak Password Requirements in janeczku/calibre-web
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-04-15 · updated 2026-06-17
- Weakness: CWE-521
Description
Weak Password Requirements in GitHub repository janeczku/calibre-web prior to 0.6.20.
Affected products
- janeczku/calibre-web: before 0.6.20 — fixed in 0.6.20
How to fix
Upgrade to a fixed version: janeczku/calibre-web 0.6.20. Check the vendor advisory for mitigations.
References
- https://github.com/janeczku/calibre-web/commit/49e4f540c9b204c7e39b3c27ceadecd83ed60e7e
- https://huntr.dev/bounties/c3d5c647-7557-40a9-aee4-24dc14882781
- https://github.com/janeczku/calibre-web/commit/49e4f540c9b204c7e39b3c27ceadecd83ed60e7e
- https://huntr.dev/bounties/c3d5c647-7557-40a9-aee4-24dc14882781
Get alerted when CVE-2023-2106 or the next vulnerability affects your stack