What’s Vulnerable › Vulnerabilities
CVE-2023-2109: Cross-site Scripting (XSS) - DOM in chatwoot/chatwoot
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-04-17 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - DOM in GitHub repository chatwoot/chatwoot prior to 2.14.0.
Affected products
- chatwoot/chatwoot: before 2.14.0 — fixed in 2.14.0
How to fix
Upgrade to a fixed version: chatwoot/chatwoot 2.14.0. Check the vendor advisory for mitigations.
References
- https://github.com/chatwoot/chatwoot/commit/a06a5a574ad908b0ef2db7b47d05c3774eeb493d
- https://huntr.dev/bounties/fd5999fd-b1fd-44b4-ae2e-8f95b5c3d1b6
- https://github.com/chatwoot/chatwoot/commit/a06a5a574ad908b0ef2db7b47d05c3774eeb493d
- https://huntr.dev/bounties/fd5999fd-b1fd-44b4-ae2e-8f95b5c3d1b6
Get alerted when CVE-2023-2109 or the next vulnerability affects your stack