What’s Vulnerable › Vulnerabilities
CVE-2023-2113: Autoptimize < 3.1.7 - Admin+ Stored Cross-Site Scripting via Settings Import
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-05-30 · updated 2026-06-17
Description
The Autoptimize WordPress plugin before 3.1.7 does not sanitise and escape the settings imported from a previous export, allowing high privileged users (such as an administrator) to inject arbitrary javascript into the admin panel, even when the unfiltered_html capability is disabled, such as in a multisite setup.
Affected products
- Autoptimize: before 3.1.7 — fixed in 3.1.7
How to fix
Upgrade to a fixed version: Autoptimize 3.1.7. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/ddb4c95d-bbee-4095-aed6-25f6b8e63011
- https://wpscan.com/vulnerability/ddb4c95d-bbee-4095-aed6-25f6b8e63011
Get alerted when CVE-2023-2113 or the next vulnerability affects your stack