What’s Vulnerable › Vulnerabilities
CVE-2023-2114: NEX-Forms < 8.4 - Admin+ SQL Injection
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 44.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-05-08 · updated 2026-06-17
- Weakness: CWE-89
Description
The NEX-Forms WordPress plugin before 8.4 does not properly escape the `table` parameter, which is populated with user input, before concatenating it to an SQL query.
Affected products
- webaways NEX-Forms – Ultimate Forms Plugin for WordPress: before 8.4 — fixed in 8.4
How to fix
Upgrade to a fixed version: webaways NEX-Forms – Ultimate Forms Plugin for WordPress 8.4. Check the vendor advisory for mitigations.
References
- https://github.com/SchmidAlex/nex-forms_SQL-Injection
- https://wpscan.com/vulnerability/3d8ab3a5-1bf8-4216-91fa-e89541e5c43d
- https://github.com/SchmidAlex/nex-forms_SQL-Injection
- https://wpscan.com/vulnerability/3d8ab3a5-1bf8-4216-91fa-e89541e5c43d
Get alerted when CVE-2023-2114 or the next vulnerability affects your stack